Table of Contents:

1. Enable Cellular Connection

If your device has a Cellular module, you can see the below screenshot. enable the cellular connection here.

image-20220601110850-2.png

Enable Cellular Connection

If your device doesn't have a cellular module, you will see a cellular module not detected.

image-20220527153544-2.png

2. How to Debug if Cellular connection fails

If there is a problem with the cellular connection. Please check the below points:

2.1 Do you order the model with a cellular option

Make sure you order the model with the cellular option. Can check by command or via the Web UI.

root@dragino-1bbd90:~# lsusb
Bus 001 Device 004: ID 2c7c:0125      --> This is the Cellular module
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

image-20220601110748-1.png

2.2 Do you input the SIM card correctly

Below command can check if you have a SIM card inserted, or via Web UI

  • Make sure to Power Off when you insert the SIM card and power on the device. The device doesn't support auto-detect SIM card on power on
  • Make sure you have the correct direction to insert the SIM card. Every device has an example photo in the manual for the direction.

root@dragino-1dadd8:~# comgt -d /dev/ttyUSB3
SIM ready
Waiting for Registration..(120 sec max)
Registered on Home network: "CHN-UNICOM",7
Signal Quality: 10,99

image-20220527153804-4.png

​​Note: If the icon is missing some information, like SIM, Network, or Signal, which may be due to the display bug.

Please check the IP address is displayed and the Internet displays "OK", it works properly.

image-20220527153827-5.png

2.3 Check dialing info

run "logread -f" in gateway CLI。

Fri Feb  7 01:20:28 2020 daemon.notice pppd[29452]: pppd 2.4.7 started by root, uid 0
Fri Feb  7 01:20:29 2020 user.notice iot_keep_alive: Ping WAN
Fri Feb  7 01:20:29 2020 user.notice iot_keep_alive: Default interface is
Fri Feb  7 01:20:29 2020 user.notice iot_keep_alive: No internet at any interface
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: abort on (BUSY)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: abort on (NO CARRIER)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: abort on (ERROR)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: report (CONNECT)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: timeout set to 10 seconds
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: send (AT&F^M)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: expect (OK)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: AT&F^M^M
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: OK
Fri Feb  7 01:20:29 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: send (ATE1^M)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: expect (OK)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: ^M
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: ATE1^M^M
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: OK
Fri Feb  7 01:20:29 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: send (AT+CGDCONT=1,"IP",""^M)
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: timeout set to 30 seconds
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: expect (OK)
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: ^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: AT+CGDCONT=1,"IP",""^M^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: OK
Fri Feb  7 01:20:30 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: send (ATD*99#^M)      -----> In case the dialling process already reach here.
Normally the problem is with a provider, need to check if the SIM card has balance or other requirement from the cellular operator

Fri Feb  7 01:20:30 2020 local2.info chat[29485]: expect (CONNECT)
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: ^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: ATD*99#^M^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: CONNECT
Fri Feb  7 01:20:30 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: send ( ^M)
Fri Feb  7 01:20:30 2020 daemon.info pppd[29452]: Serial connection established.

2.4 If the following situation occurs, how can users solve this problem?

2.4.1 The gateway can read the SIM card, But the Internet is displayed as Fail.

Users can check whether the APN matched by the SIM card is correct.

Regarding what APN your SIM card should use, Users can search for the APN corresponding to the SIM card by Google or ask the carrier.

image-20220718155937-1.png

2.4.2 The gateway can read the SIM card, But the Internet is displayed as Fail, and at the same time Network displays the carrier network.

It should be SIM card no flow, users can insert SIM cards into the mobile phone for testing.

1658131428288-728.png

2.4.3 The gateway can't read the SIM card, and the Internet is displayed as Fail.

Users need to check whether the SIM card type is suitable for the EC25 module.

1658131612484-845.png

2.4.4 SIM display:***SIM ERROR*** Check SIM is inserted test SIM in a mobile phone?

Users can insert SIM cards into the mobile phone for testing.

image-20220718160804-3.png

3. Share Cellular Network for WiFi & LAN clients

By default, the Cellular Network won't be shared with the WiFi or LAN clients. If users need to share with them, the user can modify the file.

root@dragino-1d25dc:~# cat /etc/config/firewall

config defaults
       option syn_flood '1'
       option input 'ACCEPT'
       option output 'ACCEPT'
       option forward 'REJECT'
config zone
       option name 'lan'
       list network 'lan'
       option input 'ACCEPT'
       option output 'ACCEPT'
       option forward 'REJECT' 
config zone
       option name 'wan'
       list network 'wan'
       list network 'wwan'
       list network 'wan6'
       list network 'cellular'   -----------------> Add this line and reboot
       option input 'REJECT'
       option output 'ACCEPT'
       option forward 'ACCEPT'
       option masq '1'
       option mtu_fix '1'
config forwarding
       option src 'lan'
       option dest 'wan'

and run /etc/init.d/firewall reload or reboot the device.

4. Switching between Cellular and Ethernet and Wi-Fi networks

By default, Cell is the backup WAN where the Ethernet or Wi-Fi network is used first if they are available.

Once the Ethernet of the Wi-Fi network is unavailable where the gateway network will switch to a Cell network from Ethernet or Wi-Fi.

Enable Cellular and connect Ethernet at the same time

ETH icon is displayed as ​​​ 1658135519305-444.png Indicates that Ethernet is the main working network.

Cell icon is displayed as   1658135500498-725.png  Indicates that Cellular is the backup WAN.

   

4.1 Switching between Cellular and Ethernet networks

When connecting to the AP WiFI of the gateway, users can access the Web UI of the gateway through the default address 10.130.1.1

image-20220606140622-2.png

Remove the network cable from the WAN port on the gateway, the gateway will switch to a Cellular network.

image-20220606140859-4.png

  

4.2 Switching between Cellular and WiFi networks

Enable Cellular and connect WiFi at the same time

WiFi icon is displayed as ​​​1658135519305-444.png  Indicates that WiFi is the main working network.

Cell icon is displayed as  1658135500498-725.png Indicates that Cellular is the backup WAN.

image-20220606141113-7.png

Close the WiFi WAN, the gateway will switch to a Cellular network.

image-20220606140932-5.png

4.3 At the same time start Cellular and Ethernet and Wi-Fi networks

image-20220606140328-1.png

 

5. How does the gateway view the International Mobile Equipment Identity (IMEI)

Users can get the IMEI via Linux command, but you have to access the gateway CLI.

root@dragino-1b7c4c:~# comgt -d /dev/ttyModemAT -s /etc/gcom/getimsi.gcom 

image-20221027140604-1.png

image-20221027151146-2.png

How does the gateway access the Quetel module directly (to send AT commands)

Users can access the gateway CLI and run the minicom command to get the configuration interface.

 

Enter the minicom command, then select the option ''serial port setup".

root@dragino-1ef9ac:~# minicom -s

image-20220527154132-6.png

And then, change the setting:

Serial Device : /dev/ttyModemAT

Bps/Par/Bits : 9600 8N1

Note: Enter the corresponding letter to change the configuration, like A,B,C

image-20220527154154-7.png

Enter AT+GSN in the interface to get the IMEI,

For example: 860548042566627

  AT+GSN

image-20220527154231-8.png

6. How does the gateway connect to the network via a USB 4G Dongle

6.1 Introduction

Prerequisite: Requires a USB 4G Dongle and a supported gateway firmware

This introduces a setup and configured gateway for using a USB 3g/UMTS-modem for WAN connection.

 

Many modes (and most LTE) USB modems provide qmimbimncmrndis protocol for connection instead of legacy ppp protocol, they are faster and better, overall recommended.

This is not beginner-friendly due to too many protocols.

For more information: https://openwrt.org/docs/guide-user/network/wan/wwan/3gdongle

 

6.2 How to use the USB Dongle at the gateway

Most of the products can be used on the gateway, but because their protocols are different, they are not used in the same way.

For example, the Huawei-E3372/E8372 is using Hilink mode or NCM mode.

  Huawei-E3372/E8372
  Check the E3372 version to determine the mode.
  The version numbers starting with 21 is NCM mode
  The version numbers starting with 22 is Hilink mode
  The E8372 only has Hilink mode
  
Note: The e3372 in the vast majority of cases is Hilink mode

6.3 Hilink mode

Gateway upgrade to the specified firmware:Hilink.mode--build-v5.4.1625627505

6.3.1 Plugs into the device

USB-Dongle plugs into the gateway USB port

Check the USB module via command lsusb

Note: Users need to that connect to the gateway command line via ssh.

image-20220527154739-9.png

6.3.2 Detection of new network interfaces added

Check network configuration command line input: 

  root@dragino-1ef9ac:~# ifconfig -a

image-20220527154822-10.png

In the command, the output user can see that the new interface added is eth2

Usually, the user can see that the new interface added is eth2 or wwan0

6.3.3 Add the new interface to the network configuration.

Enter the configuration from the command line:

uci set network.lte=interface
uci set network.lte.proto=dhcp
uci set network.lte.ifname=eth2    --------->#This depend on the name of the new interface gateway add
uci commit network
uci set firewall.@zone[1].network="wan wwan wan6 lte"
uci commit firewall
/etc/init.d/network restart

image-20220527154937-11.png

Checking Network Configurations

Command-line input: ifconfig

image-20220527155013-12.png

Now, Gateway is configured to access the internet on the LTE network.

6.4 NCM mode

6.5 Troubleshooting

6.5.1 The USB-Dongle interface cannot obtain the IP address.

Please try this USB dongle to access the internet on your PC, to make sure this USB dongle can normally access the internet.

7. How to reduce data traffic

7.1 Reduce Status Uplink Interval

The gateways will use the data traffic below two places.

1. There is the data traffic from LoRa package Forward which were the gateway status package and sensor end node uplink/downlink.

For this case, by default, the gateway will uplink self-status to the LoRaWAN server per the 30s. the users can adjust the interval time.

image-20220527155108-13.png

2. There is the data traffic from the gateway check self-network status. by default, the gateway will check the network per 15s.

For this case, We have monitored the loss of data traffic, which is the loss of 2M data traffic per day. the users can adjust the interval time following screenshots.

image-20220527155358-16.png

System General interface

image-20220527155229-15.png

Keepalive script interval time settings

7.2 Filter unwanted packets

See How to filter unwanted packets

7.3 Usage statistics

1. Activate LuCI and connect to SSH following these instructions

2. Install luci-app-statistics using the following terminal commands: 

opkg update
opkg install luci-app-statistics
opkg install collectd-mod-interface
/etc/init.d/collectd enable
reboot

3. Select the interface to be monitored by going to Statistics > Setup in the upper menu then Network plugins > Interfaces. Select 3g-cellular in the list then save. You can select multiple interfaces by pressing the ctrl key while selecting the interfaces. 

image-20221124133431-1.png

image-20221124135102-2.png

4. View the graphs and statistics using by going to Statistics > Graphs > Interfaces > 3g-cellullar

image-20221124134927-1.png

 

Tags:
    
Copyright ©2010-2022 Dragino Technology Co., LTD. All rights reserved
Dragino Wiki v2.0