Table of Contents:

1. Enable Cellular Connection

If your device has a Cellular module, you can see the below screenshot. enable the cellular connection here.

https://wiki.dragino.com/images/thumb/8/81/Cellular_11.png/600px-Cellular_11.png

Enable Cellular Connection

If your device doesn't have a cellular module, you will see a cellular module not detected.

https://wiki.dragino.com/images/thumb/d/da/Cellular_10.png/600px-Cellular_10.png

No Cellular Module

2. How to Debug if Cellular connection fail

If there is a problem for cellular connection. Please check the below points:

2.1 Do you order the model with a cellular option

Make sure you order the model with the cellular option. Can check by command or via the Web UI.

root@dragino-1bbd90:~# lsusb
Bus 001 Device 004: ID 2c7c:0125      --> This is the Cellular module
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

2.2 Do you input the SIM card correctly

Below command can check if you have a SIM card inserted, or via Web UI

  • Make sure to Power Off when you insert the SIM card and power on the device. The device doesn't support auto-detect SIM card on power on
  • Make sure you have the correct direction to insert SIM card. Every device has an example photo in the manual for the direction.

root@dragino-1bbd90:~# comgt -d /dev/ttyUSB3
SIM ready
Waiting for Registration..(120 sec max)
Registered on Home network: "CHN-CT",7
Signal Quality: 23,99

2.3 Check dialing info

run "logread -f" in console

Fri Feb  7 01:20:28 2020 daemon.notice pppd[29452]: pppd 2.4.7 started by root, uid 0
Fri Feb  7 01:20:29 2020 user.notice iot_keep_alive: Ping WAN
Fri Feb  7 01:20:29 2020 user.notice iot_keep_alive: Default interface is
Fri Feb  7 01:20:29 2020 user.notice iot_keep_alive: No internet at any interface
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: abort on (BUSY)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: abort on (NO CARRIER)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: abort on (ERROR)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: report (CONNECT)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: timeout set to 10 seconds
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: send (AT&F^M)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: expect (OK)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: AT&F^M^M
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: OK
Fri Feb  7 01:20:29 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: send (ATE1^M)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: expect (OK)
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: ^M
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: ATE1^M^M
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: OK
Fri Feb  7 01:20:29 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:29 2020 local2.info chat[29485]: send (AT+CGDCONT=1,"IP",""^M)
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: timeout set to 30 seconds
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: expect (OK)
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: ^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: AT+CGDCONT=1,"IP",""^M^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: OK
Fri Feb  7 01:20:30 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: send (ATD*99#^M)      -----> In case the dialling process already reach here.
Normally the problem is with a provider, need to check if the SIM card has balance or other requirement from the cellular operator

Fri Feb  7 01:20:30 2020 local2.info chat[29485]: expect (CONNECT)
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: ^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: ATD*99#^M^M
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: CONNECT
Fri Feb  7 01:20:30 2020 local2.info chat[29485]:  -- got it
Fri Feb  7 01:20:30 2020 local2.info chat[29485]: send ( ^M)
Fri Feb  7 01:20:30 2020 daemon.info pppd[29452]: Serial connection established.

3. Share Cellular Network for WiFi & LAN clients

By default, the Cellular Network won't be shared with the WiFi or LAN clients. If users need to share with them, the user can modify the file.

root@dragino-1d25dc:~# cat /etc/config/firewall

config defaults
       option syn_flood '1'
       option input 'ACCEPT'
       option output 'ACCEPT'
       option forward 'REJECT'
config zone
       option name 'lan'
       list network 'lan'
       option input 'ACCEPT'
       option output 'ACCEPT'
       option forward 'REJECT' 
config zone
       option name 'wan'
       list network 'wan'
       list network 'wwan'
       list network 'wan6'
       list network 'cellular'   -----------------> Add this line and reboot
       option input 'REJECT'
       option output 'ACCEPT'
       option forward 'ACCEPT'
       option masq '1'
       option mtu_fix '1'
config forwarding
       option src 'lan'
       option dest 'wan'

and run /etc/init.d/firewall reload or reboot the device.

4. How does the gateway view the International Mobile Equipment Identity (IMEI)

Use SSH to access the gateway configuration page and run the minicom command

Select "Serial Port Setup":

root@dragino-1ef9ac:~# minicom -s

https://wiki.dragino.com/images/thumb/0/05/4G-1.png/400px-4G-1.png

Enter the minicom command

Access the serial port of the 4G module

Serial port setup is as follows:

Serial Device : /dev/ttyModemAT

Bps/Par/Bits : 9600 8N1 or 115200 8N1

https://wiki.dragino.com/images/thumb/c/cb/EC25_1.png/400px-EC25_1.png

Configuring USB Ports

Enter AT+GSN in the serial port to view the IMEI

For example: 860548042566627

  AT+GSN

https://wiki.dragino.com/images/thumb/6/66/4G-3.png/400px-4G-3.png

Enter the AT command

5. How does the gateway connect to the network via a USB 4G Dongle

5.1 Introduction

Prerequisite: Requires a USB 4G Dongle and a supported gateway firmware

This introduces a setup and configured gateway for using a USB 3g/UMTS-modem for WAN connection.

Many mode (and most LTE) usb modems provide qmimbimncmrndis protocol for connection instead of legacy ppp protocol, they are faster and better, overall recommended. For more information: https://openwrt.org/docs/guide-user/network/wan/wwan/3gdongle

This is not beginner-friendly due to too many protocols.

5.2 How to use the USB-Dongle at the gateway

Most of the products can be used on the gateway, but because their protocols are different, they are not used in the same way.

For example, the Huawei-E3372/E8372 is using Hilink mode or NCM mode.

  Huawei-E3372/E8372
  Check E3372 version to determine the mode.
  The version numbers starting with 21 is NCM mode
  The version numbers starting with 22 is Hilink mode
  The E8372 only have Hilink mode
  
Note:The e3372 in the vast majority of cases is Hilink mode

5.3 Hilink mode

Gateway upgrade to the specified firmware:Hilink.mode--build-v5.4.1625627505

5.3.1 1.Plugs into the device

USB-Dongle plugs into the gateway USB port

Check the USB module via comman lsusb

Note : User neet to do that connect gateway command line via ssh.

https://wiki.dragino.com/images/2/25/Usb-4g.png

Checking USB Ports

5.3.2 2.Detection of new network interfaces added

Command line input: ifconfig -a

https://wiki.dragino.com/images/thumb/a/a0/Usb-4g-1.png/400px-Usb-4g-1.png

Check the network

In the command output user can see that the new interface added is eth2

Usually,user can see that the new interface added is eth2 or wwan0

5.3.3 3.Add the new interface to the network confiutation.

Enter the configuration from the command line:

uci set network.lte=interface
uci set network.lte.proto=dhcp
uci set network.lte.ifname=eth2    --------->#This depend on the name of the new interface gateway add
uci commit network
uci set firewall.@zone[1].network="wan wwan wan6 lte"
uci commit firewall
/etc/init.d/network restart

https://wiki.dragino.com/images/thumb/7/73/Usb-4g-4.png/600px-Usb-4g-4.png

Configuration

Checking Network Configurations

Command line input: ifconfig

https://wiki.dragino.com/images/b/b8/Usb-4g-3.png

Checking Network Configurations

Now, Gateway is configured to access the internet on the Lte network.

5.4 NCM mode

5.5 Troubleshooting

5.5.1 The USB-Dongle interface cannot obtain the IP address.

Please try this USB dongle to access the internet on your PC, to make sure this USB dongle can normally access the internet.

6. How to reduce data traffic

6.1 Introduce

The gateways will use the data traffic were below two places.

1. There is the data traffic from LoRa package Forward which were the gateway status package and sensor end node uplink/downlink.

For this case, by default, the gateway will uplink self-status to the LoRaWAN server per the 30s. the users can adjust the interval time.

https://wiki.dragino.com/images/thumb/b/bc/LoRa_interval_time_setting.png/600px-LoRa_interval_time_setting.png

LoRa interval time setting

2. There is the data traffic from the gateway check self-network status. by default, the gateway will check network per 15s.

For this case, We have monitored the loss of data traffic, which is the loss of 2M data traffic per day. the users can adjust the interval time following screenshots.

https://wiki.dragino.com/images/thumb/4/49/Systrm_General.png/600px-Systrm_General.png

Systrm General

https://wiki.dragino.com/images/thumb/f/f0/Set_time_interval.png/600px-Set_time_interval.png

Keppalive script interval time settings

 

Tags:
Created by Xiaoling on 2022/05/14 09:00
    
Copyright ©2010-2022 Dragino Technology Co., LTD. All rights reserved
Dragino Wiki v2.0